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About this Practice Workbook...

 This PDF file includes bookmarks providing an overview of the document. Click on the bookmark to 
quickly jump to any section in the file. You may have to turn on the bookmark function in your PDF 
viewer.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial 
values are specified first and the metric values second with the metric values enclosed in square 
brackets. For example: 12’ [3.4m] 

 This training uses the Bentley-Civil workspace delivered with the software. It is very important that you 
select the Bentley-Civil workspace when working the exercises in this course.

Have a Question? Need Help?

If you have questions while taking this course, click the button below to submit them to the Civil Design 
Forum on Bentley Communities where peers and Bentley subject matter experts are available to help.

http://learn.bentley.com
http://communities.bentley.com/products/road___site_design/f/5922#pi20290=1
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Exercise 1: Select Workspace, Create a New dgn and Explore the User Interface

Course Description
This workbook contains exercises to help you learn to navigate the user interface and find the OpenRoads Technology tools. 

Skills Taught
 How to select the proper workspace

 How to create a new .dgn

 How to navigate the user interface



Select Workspace, Create a New .dgn and Explore the User Interface

In this section we will learn to navigate the user interface and find the OpenRoads Technology tools.

The software interface is very customizable to suite your needs and preferences. The layout of the interface used in this 
training is defined as part of the Bentley-Civil workspace. If a different workspace is used, the layout of the interface 
may appear different. All of the same software functionality is available no matter which workspace is used, but some 
tools and menus may need to be selected to make them visible.

1. Start the software.

2. Select the workspace...

H
e
l

Help with the Workspace

If the Bentley-Civil-Imperial or [Bentley-Civil-Metric] projects 
are not listed, review the troubleshooting information in the 
Bentley Communities by clicking here or visiting 
communities.bentley.com and searching for “Civil Workspace”.

InRoads, GEOPAK, and PowerCivil Users

A. Select the User, Project, and Interface settings.

 User: Examples

 Project: Bentley-Civil-Imperial or [Bentley-Civil-Metric]

 Interface: Bentley-Civil

B. Click the New File icon.

Continue with step 3

MX ROAD Users

A. On the MX Project Start Up window, click New Project.

B. Click Browse and select the folder where the training 
dataset is located.

C. Key in Training in the Project Name field.

D. Set the Default MX Project Settings to UK_imperial 
[UK_metric].

E. Select the User, Project, and Interface settings.

 User: Examples

 Project: Bentley-Civil-Imperial or [Bentley-Civil-Metric]

 Interface: Bentley-Civil

F. Click OK. The MX project files are created and the
software opens into a blank file named draw.dgn.

G. Select File > New from the CAD menu.

Continue with step 3

http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/23645.troubleshooting-the-bentley-civil-workspace
http://communities.bentley.com
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3. Create a blank DGN file set up for civil work using a seed file in the Bentley-Civil workspace.

a. Click Browse.

b. Select the 2D seed file that matches your software application.

 InRoads, Power InRoads, and PowerCivil users select Seed2D-InRoads-Imperial.dgn [Seed2D-InRoads-Metric.dgn]

 GEOPAK and Power GEOPAK users select Seed2D-GEOPAK-Imperial.dgn [Seed2D-GEOPAK-Metric.dgn]

 MX users select Seed2D-MX-Imperial.dgn [Seed2D-MX-Metric.dgn]

c. Click Open.

d. Browse to the folder where the dataset is installed.

e. Type ‘North St.dgn’ in the File Name field.

f. Click Save.

The North St.dgn file is created and the New dialog closes.

g. Open North St.dgn if it’s not opened automatically
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4. If the Tasks menu isn’t already opened, hover the cursor over the ‘Tasks’ menu along the left edge of the screen. Notice that the Task 
menu appears.

Note: If the task menu does not appear, click (left mouse button) the menu to make it appear.

Hint: If the task menu is completely closed and not visible anywhere on the screen, it can be reopened by selecting Tools > Tasks.

5. Move the cursor away from the Tasks menu. Notice that the Task menu disappears.

The Tasks menu is the primary interface for selecting both drafting and civil design tools. Many people prefer to keep this menu visible all the 
time instead of having it automatically appear and disappear. This is controlled by ‘pinning’ or ‘unpinning’ the menu.

6. Make the Task menu visible.

7. Click the pin icon at the top of the menu.
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The Task menu is divided into groupings of related tools or groupings of tools that are commonly used in a work flow. The task menus (or 
groupings) are defined in a hierarchical structure. The highest menu in the structure is named Tasks. Select the down arrow next to the Tasks 
menu to display a tree view of the available menus. In the following image there are four sub-menus (Civil Tools, Print Preparation, Drawing, 
and PowerCivil Commands.

The menus available are different for each software package. However, all of the Bentley civil software 
applications will have the Civil Tools menu. All of the tools used in this OpenRoads Technology Quick 
Start are found in this menu. The Civil Tools menu contains ten toolboxes that can be expanded and 
collapsed to view the individual tools.

8. Explore the Task menu. Practice navigating to different menus.

9. Set the Civil Tools menu active.
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Exercise 2: Open Additional Views

Description
This workbook contains exercises to open additional views within the project dgn file.

Skills Taught
 How to open and close additional views within the dgn file.
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Open Additional Views

The OpenRoads tools allow us to view our design models in multiple ways and in multiple views. We will open 
additional views to utilize later to see the 3D model in dynamic, profile, and cross section views. Generally you will be 
working in a 2D drawing, but you can open an additional, independent view in order to look at the 3D model. 

Note: The 3D model can be viewed in any of the 8 views.

1. Open views 2 and 3.

2. Move these views to the right side of the screen. One above the other. They do not have to be placed exactly, just in relatively close 
alignment to how you wish them to appear.

3. On the MicroStation menu, select Window, then Arrange.

4. Go to File > Save Settings to ensure that the views and the arrangement are saved to this dgn.
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Exercise 3: Creating and Viewing Existing Ground Terrain

Description
This workbook contains exercises to create a terrain model from legacy data, attach vector and raster references to a DGN drawing file, and 
adjust the display of terrain models.

Skills Taught
 Import legacy terrain data to create an existing ground terrain model

 Attach a reference file

 Attach an existing ground terrain model

 Change how a terrain model is displayed

 Attach a raster aerial photograph.
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Create a DGN and Import Legacy Terrain Data

Terrain models are stored in DGN files. It is generally a “best practice” to create the existing terrain in a separate DGN 
file. Tools are included to allow for the import of legacy terrain formats (DTM, TIN, FIL) to create an OpenRoads or 
DGN-based terrain.

1. Create a blank DGN file to store the existing ground terrain. 

If the software is open, you may go to FILE > NEW and skip to step b. below. If you have closed the software, follow the steps below.

a. Click the New File icon.

b. Click Browse.

c. Select the 3D seed file that matches your software application.

 InRoads, Power InRoads, and PowerCivil users select Seed3D-InRoads-Imperial.dgn [Seed3D-InRoads-Metric.dgn]

 GEOPAK and Power GEOPAK users select Seed3D-GEOPAK-Imperial.dgn [Seed3D-GEOPAK-Metric.dgn]

d. Click Open.

e. Browse to the folder where the dataset is installed.

f. If using imperial units, Type ‘Existing Terrain - Imperial.dgn’ in the File Name field.

g. If using metric units, Type ‘Existing Terrain - Metric.dgn’ in the File Name field.

h. Click Save. The Existing Terrain file is created and the New dialog closes.

i. Select the appropriate Existing Terrain**.dgn.

j. Click Open.
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2. Import legacy terrain data

k. Expand the Terrain Model Toolbox in the Tasks menu.

l. Select the Create From File tool in the Terrain Model toolbox

m.Select the file Meadow Park Existing.dtm [Meadow Park Existing-Metric.dtm] to import.

NOTE: This tool can also be used to open .tin files and .fil files to create terrain models.

n. Click Done.

o. The Import Terrain Model dialog box opens.

p. In the Feature Definition drop-down menu, select Terrain Display > Existing_Boundary.

q. Verify that the Import Options drop-down menu is set to Import Terrain Only.

r. Click Import and close the dialog box.

s. Click the Fit View icon to fit the terrain to the view.

t. Review the terrain
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Attach the Terrain Model to the Project File

Terrain models are stored in DGN files which makes it easy to reference them into other files.

Note: The following exercise discusses attaching a DGN file that contains a terrain model. However, the process is exactly the same to attach 
any other drawing as a reference. Both DGN and DWG files can be referenced using this process.

1. Open the North St.dgn file created in the previous exercise. 

2. Be sure View 1 is active, then select the References icon along the top of the view or select File > References.

3. From within the References window, select Attach Reference icon or Tools > Attach.

4. Select the file Existing Terrain - Imperial.dgn [Existing Terrain - Metric.dgn].

5. Click Open.

The Reference Attachment Settings dialog appears where the behavior of the reference file is defined. There are several important 
settings to consider. The remainder of the settings can remain set with the default values.

 Orientation - defines where the reference will be located in relation to the active file. The Coincident - World setting is more common 
in civil engineering work. This setting aligns the coordinate systems of the two files.

 Nested Attachments - defines what happens to references attached to the file being referenced. For example, consider 3 files. File A 
is referenced into file B. If file B is then referenced into file C what is displayed in file C, just file B or both file A and B? That depends 
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on the nesting setting. Setting the Nested Attachments to No Nesting would result in only file B being displayed. Setting the Nesting 
Attachments to Live Nesting would result in both file A and B being displayed.

 Snap - when enabled you can ‘snap’ to elements in the selected reference. Snapping is the ability to connecting to a point (end point, 
center, etc.) on an existing element. Typically you will not need or want to snap to terrain model graphics such as contours so you will 
generally want to disable Snap for terrain model references.

 Locate - when enabled elements in the reference can be selected or located and information extracted from them. This is important for 
terrain models because you will need to select the terrain elements to review and use them.Locate should generally be enabled, 
especially for terrain model references.

6. Set the following reference attachment settings.

 Orientation: Coincident ‐ World

 Nested Attachments: No Nesting

 Snap: Disabled

 Locate: Enabled

7. Click OK.

8. Close the References window.

9. Click Fit in the top of the view window to fit all of the graphics in the active file and the reference to display within the view window.

A green outline of the terrain model boundary should be visible.

10. Select File > Save Settings to have the software remember the portion of the drawing being viewed.
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Viewing the Terrain Model

In this section we will define the 3D model view, as well as adjust the terrain model to display contours, topography, 
triangles, etc.

1. Click the Element Selection tool in the Tasks menu.

The Element Selection tool is used to pick elements so they can be edited or manipulated with other commands.

2. Set the Element Selection tool to the individual mode by selecting the Individual and New icons in the Tool Settings window.

3. Click anywhere on the green shape that outlines the terrain model. Hover the cursor at this location for a few seconds and a context 
sensitive toolbar appears displaying tools that are commonly used with this type of element. 

For a terrain element, three common tools are displayed. These and many more terrain tools are also located in the Terrain Model task 
menu. You can select the tools from either location but the context sensitive toolbox is typically the easiest and fastest way to access 
commonly used tools.

4. Select the Set As Active Terrain Model tool.

Defining a terrain model as active directs the software to default to this terrain model for most terrain tools. Setting the active terrain 
model streamlines your workflow when using other tools. You can always change or clear the active terrain model.
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Defining a terrain model as active makes the terrain tools more efficient, and also activates the 3D component of the design model. This 
activation directs the software to incorporate 3D data into the design file by creating a 3D model within the 2D design file. This 3D model 
can be viewed by opening additional MicroStation views.

5. Within View 2, select the View Attributes icon.

6. Change the Models drop-down menu to Default‐3D. View 1 and View 3 are showing the model in 2D, while View 2 is displaying the 3D 
model.

7. Close the View Attributes window

8. If the model is not visible, select the Fit View tool at the top of the window.

TIP: The views are independent and allow for differing display symbologies of the same model data.

Currently only the boundary (green line) of the terrain model is displayed. What if you want to view contours, triangles, flow arrows, low/
high points, or source features? Fortunately it is very ease to change how the terrain model is displayed. All graphical elements created in 
the Bentley civil software have properties stored with them that define the elements and how they display. One of the properties 
associated with terrain model elements is an Element Template. Element Templates are definitions that define how elements display. The 
Bentley Civil workspace includes several Element Templates for viewing terrain models.

9. If the Element Information window is NOT docked on the left of the screen, proceed to step 10. Otherwise skip step 10 and go to step 11.

10. Open the Element Information window and dock it on the right side of the screen.

Hint: If the Element Information menu is not displayed anywhere on the screen, select Element > Information to open the window.

a. Grab and drag (using left mouse button) the title bar of the Element Information window into the center of the screen.

b. Grab and drag the title bar of the Element Information window to the docking icon  on the right side of the screen.

TIP: The Element Information window will be used frequently when working in the OpenRoads Technology powered software. It is 
recommended that you keep the Element Information window docked and visible until you become more comfortable working with the 
software. As your experience increases you may want to unpin the Element Information window so that it does not take up so much 
screen space but you can still quickly access it.

c. Select the Element Information menu along the right edge of the screen, expand, and pin it so that it remains visible
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11. Select the Element Information menu along the left edge of the screen. Then expand and pin it so that it remains visible.

12. Within View 1, Use the Element Selection tool to select the terrain element.

Information about the terrain element appears in the Element Information window. The terrain element has eight categories of 
information. Each category is displayed in its down Tab which can be expanded and collapsed as necessary to view the properties.

13. Expand the General tab.

The Template property defines the Element Template currently in use to display the terrain model. However, you will find that you cannot 
change the Element Template. The property is displayed but is grayed out and unavailable to change. This is because the Terrain Model 
element is being displayed from a reference and by default is read only. 

Hint: The Override Symbology property must be enabled to change any of the referenced Terrain Model’s properties.

14. Expand the Reference tab.

15. Set the Override Symbology to Yes.

The element (terrain model) must be reselected before the Element Template can be defined.

16. With the Element Selection tool still active, click anywhere in the background of the drawing space to clear all elements from the selection 
set.

17. Select the terrain element again.
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The Template property in the General tab should now be editable.

18. Click in the field to the right of Template and then click on the down arrow to view the available Element Templates.

19. Locate and expand the Terrain group.

20. Select the Existing_Contours element template.

The terrain model display will update displaying contours in View 1 and View 3. View 2 doesn’t update, as it is an independent view 
showing the 3D model rather than the 2D model. The display of the 3D model can be changed by clicking on the terrain element within 
View 2 and editing the properties just as was done previously in the 2D views. 

21. Practice selecting some of the other element templates and explore what is displayed.
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Overriding Element Templates

Element Templates should be used to display terrain models whenever possible because they are the most efficient way to change a lot of 
display settings all at once. 

The Bentley Civil workspace provides Element Templates for a variety of common displays but those may not meet your requirements. Other 
element properties can be adjusted to override and enhance the Element Template definition.

TIP: A production environment should have Element Templates defined for all of the common ways terrain is viewed in your workflow.Using 
Element Templates is much more efficient than changing individual settings. Creating new, and editing existing, Element Templates is outside 
the scope of this training.

This exercise teaches how to display flow direction arrows with the triangles and how to change the contour interval in the Existing_Contours 
Element Template.

1. Set the terrain model to display the Existing_Triangles element template.

2. Expand the Calculated Features Display tab.

3. Set the Flow Arrows to On.

Arrows indicating the direction of water flow are displayed at the center of each triangle. The arrows will appear as blue dots until you 
zoom in close enough to see the arrow.

4. Use the Zoom In , Zoom Out , and Pan View  tools at the top of the graphic window to navigate around the drawing to 
view the flow arrows. If your mouse has a scroll wheel it can also be used to zoom in and out.

5. Verify that the terrain model is still selected. If it is, the top portion of the Element Information window will show the name of the selected 
element(s). It should show Terrain Model: Meadow Park Existing.

6. If the terrain model is not selected, use the Element Selection tool to select it again.
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7. Set the terrain model to display the Existing_Contours element template.

8. Click the + icon to expand the Terrain Model: Meadow Park Existing.

9. At the top of the dialog box, click the + icon to expand the Calculated Features Display.

10. Select Contours.

11. Select the Contours tab in the lower portion of the window.

The contour properties are displayed.

12. Change the Major Interval to 2 and the Minor Interval to 0.5 and watch the contour display update.

13. Select Terrain Model: Meadow Park Existing in the top portion of the Element Information window.

14. Select the Existing_Boundary element template.

TIP: Showing just the boundary is helpful when creating Geometry and designing Corridors because it reduces the amount of graphics 
displayed on the screen.

15. Fit the drawing so you can see the entire terrain boundary.
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Attach Raster Reference

Aerial photos can be a valuable backdrop for both design and final plan sheets. When attaching an image, you will need 
to verify the units being used by raster manager coincide with the units stored with the imagery. In this case the imagery 
is based on metric units, so we will verify the raster manager settings before ataching the image. This exercise teaches 
how to check the rater manager units and attach an aerial photo to the drawing. 

1. On the top pull-down menu, go to Workspace > Preferences. On the preferences dialog box, select Raster Manager.

2. Click the Georeference tab.

3. Change the Default Unit Settings to Meters.

4. Click OK.

5. Go to File > Save Settings.

6. Select File > Raster Manager.

7. Select the Attach icon.

8. Browse to and select the MeadowPark.tif file.

9. Click Open.

The Raster Attachment Options window appears. No changes are necessary.

10. Click Attach.

The raster aerial photo is attached to the drawing. 
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This photo includes a world file that defines the geographical position (coordinates, rotation, and scale) of the photo so it is automatically 
place in the proper space. Aerial photos that do not contain geographical positioning data can be placed interactively and warped into the 
proper place with other Raster Manager tools. These additional tools are not discussed in this class.

11. Select the MeadowPark.tif file in the Raster Manager window.

Notice that the Element Information window is populated with the properties of the raster attachment.

12. In the Element Information widow, expand the General tab.

Change the Transparency to 50.

Making the aerial photo partially transparent can make it easier to see graphics drawn over the photo.

Close the Raster Manager window.

NOTE: If the image doesn’t align properly, it’s likely that the units set for the Raster Manager are set improperly. To check the units, go to
WORKSPACE>PREFERENCES>RASTER MANAGER and verify that the default units on the Georeference tab are set to Meters.
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Exercise 4: Horizontal Alignment Creation Using Elements

Description
This set contains exercises to define horizontal centerline geometry using line and arc geometry elements.

Skills Taught
 Create horizontal geometry using line and arc element tools

 Combine individual geometry elements into a complex element

 Associate Design Standards with alignment geometry and review feedback when design standards are violated

 Define start station of the alignment

 Create horizontal alignment report
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Define Centerline Geometry Using Individual Elements

North St. is defined by two tangents connected by an arc. The west end of the street intersects South Blvd. and the east 
end intersects East Road.

1. Continue in the North St.dgn file created in the previous exercises.
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Our first action is to attach a reference that contains the Centerline for the South Blvd. This reference also contains the PI locations for the 
east road that may be used later in an optional exercise.

2. Adjust the Reference Files

a. Turn off the display of North St.dgn in View 1. 

 Set View 1 to be active and open the References dialog. Highlight the North St. reference in the list and click off the Display button.

b. Attach the South Blvd. - Imperial.dgn [South Blvd. - Metric.dgn] file as a reference. 

We will need to Snap and Locate elements in the South Blvd. file so make sure both the Snap and Locate locks are enabled when the 
reference is attached.

3. Turn on the Road_Centerline level in the South Blvd reference to display the South Blvd. geometry.

c. Select the Level Display tool.

d. Select the South Blvd reference in the top portion of the dialog. If the file/reference list is not visible, select the Show Target Tree icon.

e. Select the Road_Centerline level.

f. Close the Level Display window.
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4. Set the feature to be used for the geometry elements

a. Expand the Horizontal Geometry Toolbox in the Tasks menu.

b. Select Feature Definition Toggle Bar to open the toggle bar window.

Hint: the Feature Definition Toggle Bar can be docked at the top or bottom of the screen so it is easily accessible. The toggle bar may 
already be opened and docked. You will need to locate it even after clicking the Feature Definition Toggle Bar button. Generally, look to 
the upper left of the screen to find it docked above the Tasks menu.

c. Set the active feature to Linear > Roadway > Road_Centerline.

d. Enable the Use Active Feature Definition tool on the Feature Definition Toggle bar.

 Setting an active feature definition will cause any geometry elements created to have the active feature assigned as its Feature 
Definition (property).
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NOTE: Be sure that View 1 is active throughout the following exercises. To activate a view, simply click into the view or onto the view 
header.

5. Create the first geometry line of the North St. centerline.

a. Expand the Horizontal Geometry menu and select the Line Between Points tool.

b. Create the line approximately in the center of the existing road shown below. The exact location of the line is not important.

Hint: Notice the heads up prompting guiding you through the use of the command. The prompt for the second point includes the ability 
to key in the distance and/or direction. Click the Right Arrow to toggle between the Distance and the Direction input fields.
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6. Create the second line of the North St. centerline.

a. Select the Line Between Points tool.

b. Create the line approximately in the center of the existing road shown below. The exact location of the line is not important.

7. Create an arc connecting the two lines.

a. Select the Simple Arc tool.

b. Following the heads up prompting; Locate the first element and then the second element.

c. Define the arc radius as 127 [80].

d. Data point to accept the radius.

e. Select the Both option and data point to trim both tangents.

Note: Use the Up or Down Arrow keys to change the trim options, if necessary.
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8. Extend the end of North St. to intersect South Blvd.

a. Select the Trim to Element tool from the MicroStation tools.

b. Click on the left end of the North St. geometry.

c. Click on the South Blvd. geometry.

The North St. geometry is extended to the South Blvd.
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9. Group the North St. geometry elements into a single complex element.

a. Select the Complex by Elements tool.

b. On the dialog box, set the Method to Automatic.

c. Following the heads up prompting; select the left most element near where it intersects South Blvd.

Hint: where the element is selected is important. Each element has a midpoint. The element half that is selected contains the 
beginning point. Stationing moves forward from there. For example, if the element is selected near South Blvd, the complex element is 
created toward the north east as indicated by the direction arrow and shown in the left picture below. If the element is selected on the 
other end, the complex element is created toward the south west as shown in the right picture below.

d. Data point to accept and create the complex element.

10. Name the geometry ‘North St.’.

a. Select the Element Selection tool.

b. Select the geometry element.

c. On the context menu, select Properties. Key in “North St.” for the alignment name.

Correct Incorrect
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Evaluate Geometry Compliance with Design Standards

Centerline geometry generally must meet certain design standards to ensure a save design. OpenRoads Technology 
includes the ability to check existing geometry against design standards and even use the design standards to 
determine the geometry configuration. In this exercise we will check the East Road geometry against a standard. In a 
later exercise we will explore design standards further.

1. Clear the element selection. 

2. Expand the Horizontal Geometry Toolbox in the Tasks menu.

3. Select Design Standard Toolbar to open the toolbar.

4. Click on the left drop-down menu.

5. If using Imperial Units, select the 2-Lane (AASHTO Design Standards 2011 Design Library) > 4% Super > 40 MPH horizontal design 
standard.
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6. If using Metric Units, select the Plain and Rolling Terrain | 73-1980 and 38-1990 (Indian Roads Congress (IRC) Design Library > 50 KMP 
horizontal design standard.

7. Select Set Design Standard and following the prompt, click on the North Street geometry feature.

The active design standards are now associated with the geometry element.
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8. Look closely and you should find yellow warning  icons and/or red error  icons on the alignment. These warnings indicate 
something with the geometry violates the associated design standard. Hover the mouse over the warning icon to see the details of the 
warning.

In addition to the heads up display of the errors and warnings, they are listed in the Civil Message Center. 

The Civil Message Center is frequently pinned in the lower left corner of the screen. If not, select the Civil Message Center icon  in 
the General Geometry toolbox.

9. If using Imperial Units, change the horizontal design standard to 2-Lane (AASHTO Design Standards 2011 Design Library) > 4% Super > 
15 MPH.

10. If using Metric Units, select the Plain and Rolling Terrain | 73-1980 and 38-1990 (Indian Roads Congress (IRC) Design Library > 20 KMP 
horizontal design standard.

11. Select Set Design Standard and then click on the North Street geometry feature.

The design standard errors should disappear because the revised design speed is more appropriate for the geometry. The warnings may 
remain, allowing you to review them and decide whether the design needs to be adjusted.
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12. Define starting station to be 10+00 [1+000].

a. Expand the Horizontal Geometry Toolbox in the Tasks menu.

b. Select the Start Station tool.

c. Following the heads up prompts; locate the element.

d. Select the start position where the station will be10+00 [1+000] by either typing 0 or moving the cursor to the left most end of the 
geometry.

e. Type in the Start Station of 10+00 [1+000] and click Enter. 

13. Create a geometry report.

a. Select the Horizontal Geometry Report tool.

b. Click on the North St. geometry.

c. Follow the heads up prompts to generate a report from the beginning to the end of the geometry. Use a 10’ [3 m] interval.

d. When the report appears, select the HorizontalAlignmentReview.xsl report format.
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If desired, select Tools > Format Options to adjust the number of decimal places or format of the values in the report.

e. Select the HorizontalAlignmentIntervalXYZ.xsl report format to see a report of coordinates along the geometry at the interval 
specified previously.
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Exercise 5: Creating Vertical Geometry Using Elements

Description
This set contains exercises to define vertical centerline geometry using line and arc geometry elements.

Skills Taught
 Create vertical geometry using line and parabola element tools

 Combine individual geometry elements into a complex element

 Set an active Design Standard to have the software provide values for element creation tools (for example, curve 
lengths)

 Create vertical alignment report
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Define Centerline Vertical Geometry Using Individual Elements

The North St. profile begins by snapping the first tangent to the pavement slope on South Blvd. A parabolic curve 
connects to the next tangent. A second parabolic curve and final tangent complete the vertical profile.

1. Turn on the Road_EdgeOfPavement level in the South Blvd reference to display the South Blvd. geometry.

a. Click in View 1 to make it the active model.

b. Select the Level Display tool.

c. Select the South Blvd reference in the top portion of the dialog. If the file/reference list is not visible, select the Show Target Tree icon.

d. Select the Road_EdgeOfPavement level.

e. Close the Level Display window.
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2. Define the active design standards.

a. If using Imperial Units, select the 2-Lane > 4% Super > 15 MPH horizontal design standard.

b. Select the Stopping Site Distance vertical design standard.

c. If using Metric Units, select the Hill Road Manual | SP 48 - 1998 (Indian Roads Congress (IRC) Design Library > 20 KMP horizontal 
design standard.

d. Select the Stopping - Site Distance vertical design standard.

e. Enable the Active Design Standard lock.

3. Open the profile model.

a. Select the Element Selection tool.

b. Select North St. and continue to hover the cursor at the selection point until the context sensitive menu appears.

c. Select the Open Profile Model tool.

d. Open any view by selecting the respective button at the bottom of the screen. Profiles can be displayed in any view. You can even 
place the profile in view 3 if you choose.

e. Click inside the new view.

4. Display the centerline and edge of pavement elevation from the pavement surface of the South Blvd. on the profile.

a. Expand the Vertical Geometry toolbox on the Tasks menu.

b. Select the Profile Intersection Point tool.

Following the heads up prompting; 

 Locate Element to Show Intersection: select the centerline of North St.

 Locate Element Which Intersects: select the centerline (red line) of South Blvd.

A dot appears on the profile at the station and elevation where North St. intersects the centerline of South Blvd.

 Locate Next Element Which Intersects: select the edge of pavement (blue line) of South Blvd.

A dot appears on the profile at the station and elevation where North St. intersects the edge of pavement of South Blvd.
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c. Click Reset (right) mouse button to complete.

5. Define the first line.

This line will be snapped to the center of the two dots displayed in the previous step. The OpenRoads technology captures the Design 
Intent: that the profile line is dependent on the location of the centerline and Pavement Edge profile geometry. Therefore, if the pavement 
slope of South Road changes, the slope of this line will update automatically.

To insure that the line is snapped to the center of the dots, and not to an edge of the circle, the snap mode needs to be set to center 
mode.

a. Double click on the Center Snap icon.

b. Select the Profile Line Between Points tool.

c. Following the heads up prompting; snap and accept to each of the two dots.

Hint: The bold yellow X icon appears when the cursor is snapped to an element. Click the data (left) mouse button to accept the snap.

6. Verify the first line is snapped to the South Blvd. intersection points.

a. Select the line with the Element Selection tool.

b. Observe the display. When a geometry point is snapped to an element a small graphic appears to the lower left of the point as shown 
in the following illustrations. The illustration on the left is correct showing the graphic for both points on the line. In the illustration on the 
right, only the left point is snapped. Notice there is no graphic near the right point.

7. The snap mode needs to be set back to the Key Point Snap mode so that we can snap to the ends of lines and arcs.

a. Double click on the Key Point Snap icon.
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8. Define a parabolic curve tangent to the first line.

a. Select the Parabola From Element tool.

b. Follow the heads up prompting; select the first line, snap the start point to the end of the line, and place a parabola that has an exit 
grade of approximately -2% [-1.5%].

The curve length is automatically calculated based on the vertical curve parameter which is coming from the active design standards.

c. Select the Element Selection tool and pick the parabolic arc.

d. Select the exit grade text.

e. Type -2%[-1.5%] and press the Enter key.

The arc is updated to have an exit grade of exactly -2% [-1.5%].

9. Define a line tangent to the arc.

a. Select the Tangent Profile Line From Element tool.

b. Place a line from the end of the arc to approximately station 12+50 [1+075].

10. Place line

a. Select the Profile Line Between Points tool.

b. Following the heads up prompting; snap the line to the end of the previous line and to approximately the same elevation as the original 
ground at the ending station.
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11. Place a parabolic arc between the last two lines.

a. Select the Parabola Between Elements tool.

b. Following the heads up prompting; select the first and then the second line.

 Data point to accept the length and to trim.

NOTE: The parabolic arc length is calculated based on the design standards.

12. Edit parabolic arc.

a. Select the arc element with the Element Selection tool.

b. Select the curve length text field.

c. Type 100 [30] into the curve length field and press Enter to update the arc.

13. Group the North St. vertical geometry elements into a single complex element.

a. Select the Profile Complex by Elements tool.

b. Following the heads up prompts; select the left most element and then data to accept.

14. Name the geometry ‘North St. Profile’.

a. Select the Element Selection tool.

b. Select the geometry element.

c. In the Feature tab of the Element Information window set the Feature name to North St. Profile.
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15. Set the profile as the active profile.

a. Select the Element Selection tool.

b. Select the geometry element and hover until the context menu appears.

c. Select the Set Active Profile tool.

16. Review the profile geometry report.

a. Select the Profile Report tool.

b. Following the heads up prompting; select the geometry and then click the reset mouse button.
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OPTIONAL - Exercise 6: Horizontal Geometry Creation from Known PI’s

Description
This set contains exercises to define horizontal geometry from know PI coordinates and curve radii. The exercises also teach how to work with 
the heads-up display and element manipulators that are a major part of the OpenRoads Technology.

Skills Taught
 Understand and use Feature Definitions

 Create PI based horizontal geometry using the Complex by PI tool

 Use the OpenRoads Technology heads-up display and element manipulators

 Associate Design Standards with alignment geometry and review feedback when design standards are violated
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NOTE: Be sure that View 1 is active throughout the following exercises. To activate a view, simply click into the view or onto the view 
header.

Adjust the view so the three red circles that appear in the drawing along the East Road are visible. We will use the center of these circles 
to define the first three PIs for the East Road centerline.
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Define Centerline Geometry Using Known PIs

In this exercise we will define the geometry for the centerline of the East Road using know PI locations and curve radii. 
Feature definitions will be used so the geometry elements are created and displayed properly. The geometry will be 
checked for compliance with design standards.

NOTE: Perform the following exercises in View 1. To activate a view, simply click into the view or onto the view header.

1. Expand the Horizontal Geometry Toolbox in the Tasks menu.

2. Select Feature Definition Toggle Bar to open the toggle bar window.

Hint: the Feature Definition Toggle Bar can be docked at the top or bottom of the screen so it is easily accessible.

3. Set the active feature to Linear > Roadway > Road_Centerline.

4. Enable the Use Active Feature Definition tool on the Feature Definition Toggle bar.

Setting an active feature definition will cause any geometry elements created to have the active feature assigned as its Feature Definition 
(property).

5. Define the East Road which is defined by four PIs The first PI is located at the center of the southern most red circle. The other two red 
circles define the locations of the second and third PIs. The final PI location will be located by keyed in coordinates.

a. Locate the Key-in window. It might be docked along the top or bottom of the screen. If the Key-in window is not displayed, select 
Utilities > Keyin to open the window.

b. Select the Complex by PI tool in the Horizontal Geometry Toolbox.
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c. The active feature was set in Step 4. It is a good practice to confirm that the Feature Definition is set to use the active Feature 
Definition. The Feature Definition field in the Complex Element toolbox should ready ‘Use Active Feature’ as shown in the following 
illustration.

d. Turn on the center snap. Move the cursor to the center of the southern most circle. A yellow X appears in the center of the circle when 
the cursor is snapped to the center. Click the data (left) mouse button to accept the snap location.

e. Move the cursor to the middle red circle. Snap to the center of the circle and Data point (left click) to locate the second PI at this 
location.

Notice the dynamic display of distance and direction along the tangent element and the heads up display of the Radius.

Before placing the next PI you need to define the radius for the arc at the current PI.

f. Type 600 [180] into the heads up Radius prompt field and click Enter to store the radius value.

g. Move the cursor to the northern most red circle. Snap to the center of the circle to locate the third PI at this location.

h. Type 400 [120] into the heads up Radius prompt field and click Enter to store the radius value.
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The fourth PI will be located by keying in the XY coordinate.

i. Key xy=1088374,149790 [xy=331736,45656] into the Key-in window and click Enter.

j. Click the reset (right) mouse button to terminate the geometry creation.

6. Name the centerline geometry.

a. Select the Element Selection tool.

b. Select the centerline geometry.

c. Expand the Feature tab In the Element Information window.

d. Change the Feature Name to East Road. This is the name of the geometry feature.
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Edit Geometry Features

Geometry features are defined with ‘design intent’, meaning they remember how they were created and allow you to 
change parameters.

1. Select the East Road geometry feature if it is not already selected.

Notice the text indicating curve radii, tangent lengths, and tangent directions.

2. Move the cursor over one of the curve radii and click the text element. You can now type in a different value for the radius.

3. Click Undo to return the radius to its original value.

4. Zoom into the northern end of the geometry.

5. Make sure the geometry element is still selected.

6. Hover the cursor over the end PI.

7. Notice a circle and two arrows “manipulators” appear as well as a context sensitive menu. We will use the menu later, for now lets look at 
the arrows.
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8. Move the cursor over the left arrow and hold down the data button. Move the mouse to relocate the point holding the tangent length as a 
constant.

9. Try moving the point with the top arrow. Now you are moving the point holding the bearing angle as a constant.

10. Finally, try moving the point by selecting the circle. No constraints are applied, you can change both the tangent length and bearing angle.

11. Explore how the geometry can be edited with other manipulators on the geometry.

12. Remember to use the Undo command, or CTRL +Z to return the geometry to its original configuration.



Copyright © 2016 Bentley Systems, Incorporated 49DO NOT DISTRIBUTE - Printing for student use is permitted

Evaluate Geometry Compliance with Design Standards

Centerline geometry generally must meet certain design standards to ensure a save design. OpenRoads Technology 
includes the ability to check existing geometry against design standards and even use the design standards to 
determine the geometry configuration. In this exercise we will check the East Road geometry against a standard. In a 
later exercise we will explore design standards further.

1. Clear the element selection. 

2. Select Design Standard Toolbar to open the toolbar.

3. If using Imperial Units, select the 2-Lane (AASHTO Design Standards 2011 Design Library) > 4% Super > 20 MPH horizontal design 
standard.

4. If using Metric Units, select the Hill Road Manual | SP 48 - 1998 (Indian Roads Congress (IRC) Design Library > 30 KMP horizontal 
design standard.

5. Select Set Design Standard and then click on the East Road geometry feature.

The active design standard is now associated with the geometry element.

The warnings may remain, allowing you to review them and decide whether the design needs to be adjusted.
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OPTIONAL - Exercise 7: Creating Vertical Geometry from Known PI’s

Course Description
This set contains exercises to define vertical geometry from known PI station, elevation, and curve length.

Skills Taught
 Create PI based vertical geometry using the Profile Complex by PI tool

 Use the OpenRoads Technology heads-up display and element manipulators

 Enter Station and Elevation locations using Civil AccuDraw
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Define Centerline Vertical Geometry Using Known PIs

In this exercise we will define the vertical geometry for the centerline of the East Road using know PI locations and 
curve radii. Feature definitions will be used so the geometry elements are created and displayed properly. The 
geometry will be checked for compliance with design standards.

1. Continue in the North St.dgn file created in the previous exercises. 

2. Expand the Vertical Geometry toolbox in the Tasks menu.

3. Open the profile model.

a. Select the Element Selection tool.

b. Select the East Road and continue to hover the cursor at the selection point until the context sensitive menu appears.

c. Select the Open Profile Model tool.

d. Click in View 3 to place the profile model. OR open View 3 by selecting the 3 button at the bottom of the screen. 

e. Click inside view 3.

The existing ground profile appears as a green line in the view. If the existing ground profile is not shown you need to set the Active 
Terrain Model.

Stations are listed along the bottom and elevations along the left side of the view. The shaded areas represent the station range(s) of 
curves in the horizontal alignment.
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4. Define the East Road profile which is defined by four PIs.

a. Select the Profile Complex by PI tool.

b. The heads up display appears with a single field for the Curve Length. 

For this alignment we need to enter stations and elevations for each VPI.

c. Select the Toggle Civil AccuDraw tool. The tool is docked to the lower left corner in the Bentley Civil interface. If not already opened, 
Civil AccuDraw can be accessed from the General Geometry toolbox in the Tasks menu.

d. Type the following values into the heads up prompt fields. Press the TAB key to move to the next field.

 Curve Length: 0

 Station: 0

 Z: 205 [62.5]

e. Click the data mouse button to place the first VPI.

f. Continue placing the next 3 VPI’s using the following values.

g. Click the reset (right) mouse button to terminate the geometry creation.

VPI #2 VPI #3 VPI #4

Curve Length: 0 600 [180] 400 [120]

Station: 4+45 [135] 11+50 [350] 14+20 [433]

Z: 200 [61] 205 [62.5] 200 [61]
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5. Name the profile

a. Select the profile using the Element Selection tool.

b. Hover on the profile until the context menu opens.

c. Select the Properties button from the menu.

d. Set the Feature Name to East Road Profile in the Element Information window.

6. Set the profile as the active profile.

a. Select the profile element using the Element Selection tool and continue to hover the cursor at the selection point until the context 
sensitive menu appears.

b. Select the Set Active Profile tool.

NOTE: After setting the profile active, you will notice that it appears in View 2, or the 3D model. We defined the horizontal alignment’s 
vertical definition by setting the profile active, which in turn, placed it in 3D, within the 3D model space.

7. Disable Civil AccuDraw.

Civil AccuDraw is a great tool but should only be enabled when you are specifically using its functionality.
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