
 

 

Bentley OpenRoads Workshop 

2017 FLUG Spring Training Event 
 

 

 

 

444 - Using Civil Cells in OpenRoads

 

 

 

Bentley Systems, Incorporated 
685 Stockton Drive 
Exton, PA 19341 
www.bentley.com 



Practice Workbook
This workbook is designed for use in Live instructor-led training and for OnDemand self study. 
OnDemand videos for this course are available on the Bentley LEARN Server.

DO NOT DISTRIBUTE - Printing for student use is permitted

TRNC01645-1/0003

Using Civil Cells in OpenRoads

SELECTseries 4 (08.11.09.878)
About this Practice Workbook...

 This PDF file includes bookmarks providing an overview of the document. Click on the bookmark to 
quickly jump to any section in the file. You may have to turn on the bookmark function in your PDF 
viewer.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial 
values are specified first and the metric values second with the metric values enclosed in square 
brackets. For example: 12’ [3.4m] 

 This training uses the Bentley-Civil workspace delivered with the software. It is very important that you 
select the Bentley-Civil workspace when working the exercises in this course.

Have a Question? Need Help?

If you have questions while taking this course, click the button below to submit them to the Civil Design 
Forum on Bentley Communities where peers and Bentley subject matter experts are available to help.

http://learn.bentley.com
http://communities.bentley.com/products/road___site_design/f/5922#pi20290=1
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Exercise 1: Place a Civil Cell and Review

Description
In this exercise, you will place a T-intersection civil cell in various planimetric configurations 

Skills Taught
 Select a Civil Cell

 Place a Civil Cell with varying planimetric configurations

 Review the resulting models

 Edit the model via the Project Explorer



Place the T-Intersection Civil Cell

In this exercise, we will select a civil cell and place it into our design using multiple references and configurations. There 
are four alignment configurations in the design file. The first three will be used in this exercise, the fourth is to be used 
in an optional bonus exercise.

1. Start the software.

2. Select the workspace...

Help with the Workspace

If the Bentley-Civil-Imperial or [Bentley-Civil-Metric] projects 
are not listed, review the troubleshooting information in the 
Bentley Communities by clicking here or visiting 
communities.bentley.com and searching for “Civil Workspace”.

InRoads, GEOPAK, and PowerCivil Users

A. Select the User, Project, and Interface settings.

 User: Examples

 Project: Bentley-Civil-Imperial or [Bentley-Civil-Metric]

 Interface: Bentley-Civil

Continue with step 3

MX ROAD Users

A. On the MX Project Start Up window, click New Project.

B. Click Browse and select the folder where the training 
dataset is located.

C. Key in Training in the Project Name field.

D. Set the Default MX Project Settings to UK_imperial 
[UK_metric].

E. Select the User, Project, and Interface settings.

 User: Examples

 Project: Bentley-Civil-Imperial or [Bentley-Civil-Metric]

 Interface: Bentley-Civil

F. Click OK. The MX project files are created and the
software opens into a blank file named draw.dgn.

G. Select File > Open from the CAD menu.

Continue with step 3

http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/23645.troubleshooting-the-bentley-civil-workspace
http://communities.bentley.com
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3. Browse to the folder where you unzipped the dataset files and select the file Beginning Civil Cells-Imperial.dgn [Beginning Civil Cells-
Metric.dgn] file. We will use the alignments in the file to place a civil cell within the varying design configurations.

4. Open the Civil Cells menu.

5. Click the Place Civil Cell icon.

a. Click the browse button on the dialog to open the civil cell library.
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b. Expand the T-Intersections.dgnlib to see the civil cells stored in that library.

c. Select the Basic “T” civil cell.

 The dialog displays the planimetric layout of the selected civil cell with black lines

 The dialog also shows the reference lines on which the civil cell is based. These are the red lines and represent the baselines that 
must be present within the design file to place the civil cell. 

NOTE: The number of reference elements can vary for each civil cell.

d. Click OK

6. For configuration 1, follow the heads up prompting:

a. Locate the first reference element - Select the Secondary Road CL element

b. Locate the second reference element - Select the Thru Road EP element
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c. Select Elements to View Alternatives - Reset to Skip: Click the Reset mouse button

d. Select Corridors to be Clipped - Reset to Skip: Click the Reset mouse button

e. Accept the Civil Cell Placement: Click the Data mouse button to accept.

The Civil cell is placed.

7. Now, we can edit the civil cell placement by editing the reference elements from which it was placed.

a. Using the Element Selection tool, select the Secondary RD CL (the red line)
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b. Move the end point of the red line by using the element handlers, (the circles and arrows on the selected element). Click on the circle 
at the end point of the Secondary RD CL element and modify the angle of the intersection.

c. The civil cell placement updates.

8. Place the T-Intersection civil cell for configurations 2 and 3.

9. View the Intersection models in 3D

a. Using the view buttons, open View 2

View 2 contains the 3D model view of the intersections.

NOTE: The model’s display properties can be changed under the View Attributes menu within View 2.

b. Make View 2 active and zoom in to review one of the intersection models.

NOTE: You can rotate the view by using the View Rotation drop down menu within View 2.

10. Review the Civil Cell via the Project Explorer
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The Project Explorer provides a direct interface to review and manage data within the drawing interface. It provides mechanisms to build 
link sets to external content, manage CAD standards, and access drawing files and models. OpenRoads uses these mechanisms as a 
direct interface into the survey, civil design data, and standards. We will use the Project Explorer to review the civil cells we have placed 
into our design.

a. Open the Project Explorer by clicking the icon on the MicroStation primary toolbar or by going to File > Project Explorer on the drop 
down menus across the top of MicroStation.

b. Select the Civil Model tab.

c. Expand the menu under the file name - Beginning Civil Cells-Imperial.dgn [Beginning Civil Cells-Metric.dgn].

d. Expand the Civil Cells heading. 

Note that the civil cells which are present in the active dgn are listed.

e. Continue through the hierarchy and expand the Civil Cell: Basic “T”
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f. Expand the Dependent Elements heading.

Each of the design elements that make up the civil cell are listed. These elements include the stored rules and relationships that were 
defined when constructed. Civil cells store the “design intent” as well the graphical elements. Therefore, intelligent edits can be made 
to the elements within the cell after placement to address varying design scenarios.

g. Expand the element titled Linear Template: RdEOP8

h. Expand the Templates heading and Right Click on Template Drop [0+00-0+54.96]

NOTE: The station range for your template drop may be different from that shown above. The station range has changed based on the 
modifications that we made to the reference elements earlier in the exercise.

i. Select Edit Template Drop

j. Delete the end conditions and the sidewalk components from the template.

NOTE: To delete the end conditions 
and components, Right Click in the 
template window, select Delete 
Components from the drop down 
menu, and draw a line across each 
of the elements you wish to delete.

k. Click OK.
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l. Review the T-Intersection model. Notice the sidewalk and sideslopes have been removed along the Northwest curb return.
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Exercise 2: Place the T-Intersection Civil Cell in a Design Scenario

Description
In this exercise, you will place a T-intersection civil cell in a more real-world design scenario.

Skills Taught
 Placing an intersection civil cell

 Clipping an existing corridor with the civil cell

 Combining the civil cell model with a roadway corridor model
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Place the Civil Cell and Model the Intersection

In the following exercise you will use the basic T-Intersection civil cell to construct the model between two intersecting corridors. We will clip 
the existing South Blvd corridor when we place the civil cell. Also, it’s important to recognize that we will place the civil cell in view 1, the 2D 
view, and the 3D model will be constructed from it’s placement.

1. Open the file T-Intersection-Imperial.dgn [T-Intersection-Metric.dgn].

2. Open the Place Civil Cell tool.

3. Select the civil cell named “Basic T”.

4. In View 1, follow the prompts:

a. Select the Secondary Road CL

b. Select the Through Road EP

c. Click Reset to skip viewing the alternatives

d. Select the South Blvd corridor to be clipped and Reset to complete the step.

The Civil Cell can automatically clip the South Blvd. corridor where it overlaps the civil cell. In some situations, such as if the corridor 
exists in a referenced dgn file, the corridor may need to be clipped manually.
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e. Data point (Left Click) to Accept the civil cell placement. After processing, the intersection model is constructed.

NOTE: Civil cell clipping does not clip out the planimetric graphics of the corridor in View 1. In the image above, View 1 (2D view) on 
the left represents the visual interface in which we interact with the model. It is not just graphics. This 2D view is the window, or 
interface, into the “database” where the design intent as well as the design elements are stored. The graphics displayed in View 1 are 
not intended to be used for plan production, rather they are to be used as the means to edit and interact with the design model itself.

5. Review the civil cell placement. Verify that your intersection is aligned properly as shown in the image above. 

 If the cell is placed incorrectly, you may have mistakenly selected the wrong reference element during the placement. 

 To undo the civil cell placement, you can go to Edit > Undo Place Civil Cell on the MicroStation drop-down menus or key in CTL+Z.

 Place the civil cell again.
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6. Finally, we can remove the gap between the intersection and the existing 2 lane corridor.

a. Select the Template Drop handle within view 1. 

b. Using the manipulator arrow, drag the handle and the corridor start station to meet the end of the civil cell placement.

c. Snap the corridor start to the end of the civil placement to resolve the gap.
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Exercise 3: Place Sidewalk Ramps Within the Intersection Model

Description
In this exercise, you will place sidewalk ramps within the intersection model using a civil cell.

Skills Taught
 Placing a sidewalk ramp civil cell

 Using a civil cell from an external source

 Using several references to place a civil cell

 Moving the sidewalk ramp within the model
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Place a Sidewalk Ramp within the Intersection

In the following exercise you will construct sidewalk ramps within the intersection model. The civil cell we will use for the 
ramps will be pulled from a source outside of our training workspace.

1. Continuing in the file T-Intersection-Imperial.dgn [T-Intersection-Metric.dgn]

(Optional) Clean Up the View
NOTE: The graphic handles displayed with the OpenRoads elements, such as the corridors and template drops, are classified as 
“construction” elements in MicroStation. Therefore their display can be turned off or on via the constructions button within the View Attributes 
menu. The definition of these elements as construction elements is specified within the OpenRoads workspace and can be changed.

a. In View 1, open the View Attributes menu.

b. Click the Constructions button to turn off the construction elements within the dgn view.

c. If you turn off the construction elements now, you will have to turn them back on later when placing the ramp civil cell.

Reference the Sidewalk Ramp Civil Cell into the DGN
OpenRoads allows you to select and place a civil cell from dgn’s or dgnlib’s that are outside the active workspace. We 
will reference an external file containing the sidewalk ramp cell, then use it to place the ramp into our intersection 
model.

2. Open the References dialog.

a. Select Tools.

b. Select Attach.

c. Browse to the training directory and select the file Sidewalk‐Ramp.dgn.
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d. Set the Attachment Method to Coincident World.

e. Click Open

f. Close the References dialog.

g. The dgn is attached as a reference file.

3. To easily view the attached reference and the civil cell that it contains, open View 8 and arrange the views to your preference. 

4. Using the Element Selection tool, select the sidewalk ramp elements and verify that the referenced file contains a civil cell.

NOTE: You will have to Reset (Right Click) several times to swap between the overlapping elements and select the actual civil cell.

The sidewalk ramp civil cell used in this course is not intended to be utilized for production. It may not satisfy the innumerable circumstances 
and scenarios that may be encountered in the engineering practice. It is solely intended to be used within this training course.
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Draw the Sidewalk Ramp Centerline
This civil cell contains 4 reference elements and requires they be identified in the design model as the civil cell is 
placed. The gutter line and the back of sidewalk were created previously, but the ramp centerline was not. We will 
create a ramp centerline to be the basis for our ramp location within the model.

5. On the Horizontal Geometry task menu, select Line Between Points.

a. Key-in a name for the line, such as Ramp CL.

b. Activate the Perpendicular snap to place the line perpendicularly along the gutter flow line (cyan line).

c. Place the line near the middle of the northwest curb return of the intersection. Be sure to extend the line past the back of the sidewalk.

1
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Select and Place the Ramp Civil Cell into the Intersection Model
We will select the referenced civil cell and place it into our intersection model.

6. With View 8 still open, select the Place Civil Cell tool.

a. AFTER the Place Civil Cell dialog opens, click Reset (Right Click) on your mouse.

 The heads-up prompt changes to Locate Civil Cell

b. Follow the heads-up prompts:

 Select the ramp civil cell in View 8

 The Place Civil Cell dialog updates

NOTE: If not already displayed, turn on the construction elements to see the corridor handles and other OpenRoads elements.

7. Follow the heads-up prompts to place the ramp into the intersection model. Be sure to carefully follow each prompt when selecting the 
reference elements.

a. Locate the reference elements within the model following the prompts on the cursor.
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b. Cick Reset (Right Click) to Skip viewing the alternatives

c. Select the Corridor to be Clipped - select the corridor element along the curb radius as shown below..

d. Click Reset (Right Click) to Complete the step

e. Click a Datapoint (Left Click) to Accept the civil cell placement
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8. The sidewalk ramp is placed into the model.

9. Review the sidewalk ramp’s horizontal placement. If the civil cell’s placement is not correct, undo the command by going to Edit > Undo 
Place Civil Cell or key in CTRL+Z.

We will now densify the template drops within the model to remove the gaps between the sidewalk ramp and curb.

10. Select the Edge of Pavement Feature in View 1.

11. Select the Properties icon from the context menu.

12. Change the Curve Stroking settings to 0.001.
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13. Review the sidewalk ramp.

14. Notice the closer template spacing around the edge of pavement feature, as well as the curb and gutter transitions.

15. Change the attributes of the 3D view to Smooth.

16. We can relocate the ramp along the radius.

a. In View 1, select the Ramp CL element.

b. Click onto the circle at the midpoint of Ramp CL line to move the ramp along the gutter 
line. Data point to relocate the line and ramp.

NOTE: As an alternate technique, we could place the ramp centerline using the Place 
Smartline or Place Line tools in MicroStation. However, these MicroStation tools do not store 
the “design intent” associated with the element’s creation. It will not provide the flexibility to 
intelligently move the ramp after its placed. Therefore, we will use the OpenRoads geometry 
tools to place the ramp centerline. These tools create and store the design intent and will allow 
the ramp to be moved easily along the roadway after placement.
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Exercise 4: Place a Pond Into the Model

Description
In this exercise, you will learn how to place a pond within the model using a civil cell.

Skills Taught
 Placing a pond using a civil cell

 Modifying the civil cell

 Dropping and re-creating a new civil cell

 Dynamically modifying the pond civil cell to suit the design needs
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Place Ponds into the Model

In the following exercise, we will place a pond adjacent to the intersection. The basin civil cell delivered in the standards 
is designed for larger pond volumes and does not work well for the small pond near the intersection. We will place Pond 
1 (see the image below) using the typical basin civil cell delivered in the standards and modify the target volume 
associated with this civil cell. The modified civil cell will then be used to model Pond 2 (see the image below).

1. To begin, remain in your current file and turn on the level named A_POND_BOTTOM. Or if you prefer, you can open the file Completed T-
Intersection-Imperial with Ponds.dgn [Completed T-Intersection-Metric with Ponds.dgn]
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2. Zoom to the Pond 1 location in the file.

3. Open the Place Civil Cell tool.

4. Select the civil cell named Basin.

5. In View 1, follow the prompts:

a. Select the Bottom of the Basin shape. This is the light blue oval.

b. Click Reset to skip viewing the alternatives

c. Accept the civil cell placement

6. The civil cell is placed and the pond is created.
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Modify the Volume of the Pond

1. In the 3D view, select the volume line.

2. Then select the Properties button that appears on the context menu.

3. Change the Target Volume from 500000 to 50000. [14158.50 to 1415.85]
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Drop the Civil Cell
At this point, we have placed the standard basin civil cell and modified its target volume to better suit the small pond. In 
order to create a new civil cell with the modified target volume, we first have to drop the existing basin civil cell. 
Dropping the civil cell is equivalent to dropping an element in MicroStation. We are taking a complex element comprised 
of multiple entities and dropping it to its more simple, individual elements. So, one civil cell becomes several separate 
corridors, terrains, etc. once dropped.

1. From Project Explorer panel, expand the Civil Cells menu.

2. Right click on the civil cell named Basin.

3. From the drop-down menu, select Drop Civil Cell.

NOTE: The heading for the civil cell named Basin is no longer in the list of civil cells.
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Create a New Civil Cell for a Pond
After revising the volume parameters and dropping the previously placed civil cell, we will create a new civil cell from it 
to utilize elsewhere on our project site.

1. From the Civil Cells menu on the Tasks panel, select the Create Civil Cell tool.

a. Following the prompts, name the new civil cell “Proposed Pond.”

b. Select the reference element. This is the light blue oval that represents the pond bottom.

c. AFTER selecting the reference element, key in “Pond Bottom” on the dialog box in the reference name field.

d. Locate Reference - Reset to complete

e. Locate Optional Reference - Reset to Complete

f. Accept the civil cell.
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Create a Pond Adjacent to the Intersection
We will use the newly created civil cell to build a detention pond in the area adjacent to the intersection we modeled 
earlier.

1. Zoom into Pond 2.
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2. Select the Place Civil Cell tool.

3. Open the civil cell library and select the newly created “Proposed Pond” civil cell.

NOTE: There’s now a heading to select civil cells from the Active DGN in the civil cell library menu.

4. Select and hover over the pond bottom outline (the cyan line) to place the civil cell.

NOTE: The civil cell cannot be placed because the pond bottom doesn’t have a vertical 
definition. To place the civil cell, we will need to assign a vertical elevation to the pond 
bottom element.

5. Reset to exit the Place Civil Cell command.
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6. Expand the Civil Tools menu on the Tasks menu.

7. Open the Vertical Geometry tools menu.

8. Click the Profile By Constant Elevation tool.

This tool will assign and activate a user-defined vertical profile of constant elevation to an element

9. Following the prompts:

 Locate the First Element by selecting the outline of the pond bottom.

 Reset to End by RT clicking

 Key in 194.00 [59.13] for the elevation.

 Accept the elevation by LT clicking.

NOTE: For the pond civil cell to place properly, the profile must be defined and Active.

10. Now we are ready to place the pond. Select the Place Civil Cell tool.

11. Select the civil cell named “Proposed Pond” and follow the prompts to place the civil cell.
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12. The civil cell is placed and the pond is created.

NOTE: The civil cell’s reference element, which is the pond bottom shape, was created using MicroStation tools. Modifications to the 
pond model’s layout can be made by simply changing the reference element (the Pond Bottom) from which the pond was created usig 
MicroStation tools.

13. Using the MicroStation “Modify” tools, Insert a Vertex into the pond bottom shape in View 1.

14. Select the pond bottom element and modify one of the vertices of the shape to 
see the pond model update. Notice the changes in the 2D view as well as the 3D 
view.

15. Using the MicroStation Move tool, you may even relocate the pond by moving the 
entire pond bottom shape.
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